Installazione di Joomla 2.5 in locale: XAMPP ed errore PHP

Installazione di Joomla 2.5 in locale: XAMPP ed errore PHP

  • Blog
  • Letto 2672 volte

Chi mi conosce sa benissimo che uso Mac OS da diversi anni e non ho mai avuto problemi a creare un web server dove poter installare Joomla e lavorare in locale. 

Ho avuto però l’esigenza di installare windows sul mio Mac per il corso per webmaster base che sto organizzando a . Più che altro volevo essere sicuro di riuscire a installare senza problemi un web server su Windows onde perdere tempo durante il corso.
Problemi che OVVIAMENTE sono sorti
Ho installato infatti l’ultima versione di XAMPP (1.8.3) e ho configurato la password del DB Mysql. Quando ho provato però a installare Joomla 2.5, il sistema mi ha “sputato” questo errore

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in C:\xampp\htdocs\joomla\libraries\joomla\filter\input.php on line 652

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in C:\xampp\htdocs\joomla\libraries\joomla\filter\input.php on line 654

Dopo un attimo di smarrimento (Con MAMP non avevo mai visto questo errore) googlando ho scoeprto che la versione di XAMPP 1.8.3 ha una versione di php non supportata da Joomla 2.5.
Per questo motivo ho cancellato questa versione di XAMPP installando una precedente, precisamente la 1.7.3 che potete scaricare qui

{facebookpopup}

Contattami


contattami.png

Sign up to keep in touch!

Se mi lasci la tua mail ti invierò comunicati stampa inerenti alla mia attività


Ovviamente puoi cancellarti quando lo ritieni opportuno